ABS sensor

All aspects of tuning,modification and repairs to the BX 16valve.
Post Reply
douglas851
Posts: 4
Joined: Mon Aug 10, 2009 1:02 pm
Location: hastings

ABS sensor

Post by douglas851 » Thu Sep 10, 2009 9:09 pm

Help!!

The rear abs sensor has gone open ciruit inside the sensor, so I need a new one.

Citroen quote £200 :shock:

Does anyone know a supply of cheaper ones?

Thanks, Douglas

User avatar
Jezziebx16v
Moderator
Posts: 575
Joined: Tue Jun 27, 2006 3:13 pm
Location: Alberta, Canada

Post by Jezziebx16v » Thu Sep 10, 2009 9:30 pm

Give Craig at CMS a call, not sure he will have a new one but I am sure he will have a used one knocking around. Bexhill 734340
Past 16v's: 89 Ph1 Black, 90 Ph2 Grey, 89 Ph2 Black, 91 Ph2 Grey, 91 Ph2 Black.

Now. 94 Datsun Silvia S14 rice rocket, 85 Peugeot 505 Turbo, 77 Ford Capri.

User avatar
mechuccio
3000 rpm
Posts: 176
Joined: Tue Dec 19, 2006 3:18 pm
Location: Roermond, The Netherlands
Contact:

Post by mechuccio » Thu Sep 10, 2009 10:17 pm

Hey Douglas,

I just sent you a message on the BX club forum.
I've got one for you, we'll just need to sort out what the shipping cost will be.
I'll try to find out what the shipping costs are to get it over to your house!
You can't spell slaughter without laughter ->I just love my 16V<-

User avatar
Dr.Jones
Tick Over
Posts: 12
Joined: Wed Nov 05, 2008 11:21 pm
Location: Hamburg - Deutschland

Post by Dr.Jones » Mon Sep 28, 2009 10:48 pm

Xantia-ones fit also. Are much more cheaper. But you have to sold the wires together.

Image

Image

Jones
1990 BX 16V Ph2, ETB, AC
1990 BX 16V Ph2, EWT
1991 BX 16V Ph2, EXY
1990 BX 16V Ph2, Gris Axinite
1987 BX 16V Ph1, EXY

Pete H
Posts: 8
Joined: Fri Jan 03, 2014 12:54 pm
Location: St Michel

Post by Pete H » Sun Jan 05, 2014 7:50 pm

This is nice info, becouse i have the same problem with my 16V, both are dead from the back.
Remember to smile!

Harvey12
Posts: 5
Joined: Mon Mar 17, 2014 2:42 pm
Location: London

Post by Harvey12 » Fri Mar 28, 2014 4:19 pm

Learn something new everyday, even if it is from a long time ago.

I did not know I could sub the Xantia units doing that. That is going to save a few headaches for trying to locate the "right one".

User avatar
frog
3000 rpm
Posts: 163
Joined: Sat Feb 26, 2011 2:56 pm
Location: Australia

Post by frog » Sat Mar 29, 2014 7:36 am

My light came on about a month ago. Arghhh

User avatar
Mike P
Moderator
Posts: 1181
Joined: Mon Jul 03, 2006 11:46 am
Location: Leicester, UK

Post by Mike P » Sat Mar 29, 2014 10:48 am

I found with the Xantia one that the cable had to be spliced together, which was ok when the car was at idle and not moving but at above 10mph the dashlight would come on.

Probalby a sign of how good my wiring is, but this would get it through an MOT :lol:

I currently have a good contact with an instrumentation and sensor company that might be able to assist us with getting replacement ABS leads made up, will keep you all posted.

Mike P
Founder member of the Phase 1 Appreciation Society!
- - - - -
'88 'F' White Bx16v - 62k miles & as seen on TV

Post Reply