Wont Idle when HOT

All aspects of tuning,modification and repairs to the BX 16valve.
Post Reply
User avatar
Vanny
Web Support
Posts: 1480
Joined: Tue Jun 06, 2006 10:11 am
Location: elsewhere

Wont Idle when HOT

Post by Vanny » Sun Sep 22, 2019 12:08 pm

A conundrum for you. Car drives, generally pulls like a train but hunts around like a baddun at 1800rpm (all gears). Idles okay when cold, actually idles quite nicely. But it won't idle when hot. Specifically revs will drop to about 600rpm (indicated) and the battery low light will flash, then sometimes it will flare back up to 1200rpm then start to settle out till it hits 600rpm. Sometimes it will just stall.

Have pulled the connection to each injector and this seems to make things worse (which I take as good, injectors are working, wiring is working). Have pulled the Coolant Temperature Sensor (CTS) which triggers the MIL but makes not difference. I've measures across the CTS and got 280Ohms which based on the table below suggests a good reading.

I've just repaired/replaced the ignition harness (ECU to Amp to Ignition Coil) so I guess it could be this, but having checked it electrically the wiring is sound, resistances low and good supply to the coil etc I noticed there is a small crack in the potting on the top of the coil (Ducellier), but going by the dirt that's in it, its been that way for a long long time.

So, suggestions?

Image

User avatar
Vanny
Web Support
Posts: 1480
Joined: Tue Jun 06, 2006 10:11 am
Location: elsewhere

Re: Wont Idle when HOT

Post by Vanny » Mon Sep 23, 2019 7:26 pm

So, i'm thinking somewhere between an air leak after the AFS or the ISCV.

The ISCV is an original one, Bosch, two wire. So its just a plain voltage on one side, and ground out through the ECU to excite the solenoid and open/close the valve to give the bypass around the throttle when at idle.

I seem to remember something about filling it with WD40 and leaving it overnight. Well I'll try cleaning it up and cycling it on the bench when the weather dries up a bit. And as like everything else for the car, there is a spare in the garage (a brand new one at that).

User avatar
Vanny
Web Support
Posts: 1480
Joined: Tue Jun 06, 2006 10:11 am
Location: elsewhere

Re: Wont Idle when HOT

Post by Vanny » Wed Oct 02, 2019 8:08 pm

Well, its not the mechanics of the ICSV, its opening and closing quite happily when 12v is applied;
Open/Powered
ICSV Open.jpg
ICSV Open.jpg (62.53 KiB) Viewed 168 times
Closed/Un-powered
ICSV Closed.jpg
ICSV Closed.jpg (60.98 KiB) Viewed 168 times

User avatar
Dave
3000 rpm
Posts: 164
Joined: Fri Aug 18, 2006 7:43 pm
Location: depends where it takes me.

Re: Wont Idle when HOT

Post by Dave » Thu Oct 03, 2019 11:46 am

Keeping a watch on progress, I doubt it will solve the issue but as well as the other items you are checking, are all your earth connection points clean, the one under the battery, to the n/s wing and to the engine. Also the throttle position sensor, a bit of a clean up may help.
If the issue appeared after the harness change it does seem strange.
Prefer it to the Lamborghini, like Signor Gandini!

User avatar
Vanny
Web Support
Posts: 1480
Joined: Tue Jun 06, 2006 10:11 am
Location: elsewhere

Re: Wont Idle when HOT

Post by Vanny » Thu Oct 03, 2019 3:58 pm

Issue after wiring change AND 4 months standing, and something that completely flattened the battery to 2v.

Earth point on the body is completely renewed, cleaned, vaselined, multiple replacement connectors for heavily corroded ones.

Earths on the fuel rail also cleaned up.

The ignition loom was swapped for a better condition one with some tarting, so should be like for like. Only the sensor harness was remade so shouldn't have an impact.

But you know what that means . . .

User avatar
Dave
3000 rpm
Posts: 164
Joined: Fri Aug 18, 2006 7:43 pm
Location: depends where it takes me.

Re: Wont Idle when HOT

Post by Dave » Thu Oct 03, 2019 6:13 pm

Vanny wrote:
Thu Oct 03, 2019 3:58 pm


The ignition loom was swapped for a better condition one with some tarting, so should be like for like. Only the sensor harness was remade so shouldn't have an impact.

But you know what that means . . .
It should, it shouldn't and I do. :wink:
Prefer it to the Lamborghini, like Signor Gandini!

Post Reply